• 【HCIP】重发布及路由策略的实验


    实验要求

    1. 使用双点双向重发布
    2. 所有路由器进行最佳选路
    3. 存在备份路径,不得出现环路和路由回馈
    4. R1除本身环回外,外加几条环回
      172.16.1.0/24 deny
      172.16.2.0/24 type 1
      172.16.3.0/24 cost 6
      172.16.4.0/24 type 1 cost 9
      更改如上参数
      在这里插入图片描述

    实验过程

    配置IP

    //R1 - 例
    #                                         
    interface GigabitEthernet0/0/0            
     ip address 12.1.1.1 255.255.255.0        
    #                                         
    interface GigabitEthernet0/0/1            
     ip address 14.1.1.1 255.255.255.0                           
    #                                         
    interface LoopBack0                       
     ip address 1.1.1.1 255.255.255.0         
    #                                         
    interface LoopBack1                       
     ip address 172.16.1.1 255.255.255.0      
    #                                         
    interface LoopBack2                       
     ip address 172.16.2.1 255.255.255.0      
    #                                         
    interface LoopBack3                       
     ip address 172.16.3.1 255.255.255.0      
    #                                         
    interface LoopBack4                       
     ip address 172.16.4.1 255.255.255.0
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22

    起协议

    //RIP
    //R1
    rip 1                                     
     undo summary                             
     version 2                                
     network 1.0.0.0                          
     network 172.16.0.0                       
     network 12.0.0.0                         
     network 14.0.0.0                         
    //R2
    rip 1                                     
     undo summary                             
     version 2                                
     network 2.0.0.0                          
     network 12.0.0.0
    //R4
    rip 1                                     
     undo summary                             
     version 2                                
     network 14.0.0.0
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    //OSPF
    //R2
    ospf 1 router-id 2.2.2.2                  
     area 0.0.0.0                             
      network 23.1.1.2 0.0.0.0
    //R3
    ospf 1 router-id 3.3.3.3                  
     area 0.0.0.0                             
      network 3.3.3.3 0.0.0.0                 
      network 23.1.1.3 0.0.0.0                
      network 34.1.1.3 0.0.0.0                
    //R4
    ospf 1 router-id 4.4.4.4                  
     area 0.0.0.0                             
      network 4.4.4.4 0.0.0.0                 
      network 34.1.1.4 0.0.0.0
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16

    路由表展示
    在这里插入图片描述
    在这里插入图片描述

    双向重发布

    //R2
    ospf 1 router-id 2.2.2.2                  
     import-route rip 1                       
     area 0.0.0.0                             
      network 23.1.1.2 0.0.0.0                
    #                                         
    rip 1                                     
     undo summary                             
     version 2                                
     network 2.0.0.0                          
     network 12.0.0.0                         
     import-route ospf 1
    //R4
    ospf 1 router-id 4.4.4.4                  
     import-route rip 1                       
     area 0.0.0.0                             
      network 4.4.4.4 0.0.0.0                 
      network 34.1.1.4 0.0.0.0                
    #                                         
    rip 1                                     
     undo summary                             
     version 2                                
     network 14.0.0.0                         
     import-route ospf 1 
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    • 24

    路由表展示
    在这里插入图片描述
    在这里插入图片描述
    可以发现R4的路由表与重发布前一致,故没有出现路由回馈
    但是R2的路由表与重发布前不一致一致,R4环回4.4.4.4在OSPF与RIP发送方式不一样导致产生路由回馈,在R2路由表中产生两条路由

    //解决方案:修改R4环回的OSPF工作方式
    [R4]interface LoopBack 0
    [R4-LoopBack0]ospf network-type broadcast
    
    • 1
    • 2
    • 3

    此时再查看R2路由表,无4.4.4.4/32
    在这里插入图片描述

    也可以将地址改为4.4.4.4/32,此时将没有4.4.4.4/24地址

    连通性测试:R1环回 ping R3环回
    在这里插入图片描述

    干涉选路

    R1对OSPF和R3对RIP中的任一网段都为等开销负载均衡
    在这里插入图片描述
    但实际上上下两条路存在不同,我们分别在R2与R4上干涉选路 — 使用偏移列表

    //R2
    [R2]ip ip-prefix a permit 4.4.4.0 24
    [R2]ip ip-prefix a permit 34.1.1.0 24
    [R2]interface g0/0/0
    [R2-GigabitEthernet0/0/0]rip metricout ip-prefix a 2
    //R4
    [R4]ip ip-prefix a permit 23.1.1.0 24
    [R4]int g0/0/1
    [R4-GigabitEthernet0/0/1]rip metricout ip-prefix a 2
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9

    在这里插入图片描述
    此时R1到R3的选路已经完成,接下来在OSPF中干涉选路,使用华为路由策略

    //将不佳路由的类型2改为类型1
    //R2
    [R2]ip ip-prefix b permit 2.2.2.0 24
    [R2]ip ip-prefix b permit 12.1.1.0 24
    [R2]route-policy b permit node 10
    Info: New Sequence of this List.
    [R2-route-policy]if-match ip-prefix b
    [R2-route-policy]apply cost-type type-1
    [R2-route-policy]q
    [R2]route-policy b permit node 20	//空表,允许所有
    Info: New Sequence of this List.
    [R2-route-policy]q
    [R2]ospf 1
    [R2-ospf-1]import-route rip route-policy b	//重发布
    //R4
    [R4]ip ip-prefix b permit 14.1.1.0 24
    [R4]route-policy b permit node 10
    Info: New Sequence of this List.
    [R4-route-policy]if-match ip-prefix b
    [R4-route-policy]apply cost-type type-1
    [R4-route-policy]q
    [R4]route-policy b permit node 20
    Info: New Sequence of this List.
    [R4-route-policy]q
    [R4]ospf 1
    [R4-ospf-1]import-route rip route-policy b
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    • 24
    • 25
    • 26

    在这里插入图片描述
    此时仅R1环回等开销负载均衡

    更改R1环回参数 – 华为路由策略

    //R2
    ip ip-prefix R1-1 index 10 permit 172.16.1.0 24
    ip ip-prefix R1-2 index 10 permit 172.16.2.0 24
    ip ip-prefix R1-3 index 10 permit 172.16.3.0 24
    ip ip-prefix R1-4 index 10 permit 172.16.4.0 24
    #
    route-policy b permit node 10             
     if-match ip-prefix b                     
     apply cost-type type-1                   
    #                                         
    route-policy b deny node 20               
     if-match ip-prefix R1-1                  
    #                                         
    route-policy b permit node 30             
     if-match ip-prefix R1-2                  
     apply cost-type type-1                   
    #                                         
    route-policy b permit node 40             
     if-match ip-prefix R1-3                  
     apply cost 6                             
    #                                         
    route-policy b permit node 50             
     if-match ip-prefix R1-4                  
     apply cost 6                             
     apply cost-type type-1                   
    #                                         
    route-policy b permit node 60
    #                                         
    ospf 1 router-id 2.2.2.2                  
     import-route rip 1 route-policy b
    //R4 - 同上
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    • 24
    • 25
    • 26
    • 27
    • 28
    • 29
    • 30
    • 31

    路由表展示
    在这里插入图片描述
    在这里插入图片描述
    连通性测测试:
    在这里插入图片描述

  • 相关阅读:
    Debian 12安装Docker
    spring的一个properties配置文件,引用另外一个properties配置的变量
    DDOS防护如何建设?
    Caller 服务调用 - HttpClient
    【Java并发】聊聊ReentrantReadWriteLock锁降级和StampedLock邮戳锁
    前端入门学习笔记四十三
    计算机视觉与深度学习-循环神经网络与注意力机制-Attention(注意力机制)-【北邮鲁鹏】
    SSH在线聊天室系统
    SCI论文写作的时态用法
    Java基于SpringBoot的会员制医疗预约服务系统,可作为毕业设计
  • 原文地址:https://blog.csdn.net/SuichI314/article/details/126036388