• 1035 Password


    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa

    Sample Input 2:

    1
    team110 abcdefg332

    Sample Output 2:

    There is 1 account and no account is modified

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333

    Sample Output 3:

    There are 2 accounts and no account is modified

    #include<iostream>
    #include<vector>
    using namespace std;
    int main(){
        int n;
        cin>>n;
        vector<string> v;
        for(int i=0;i<n;i++){
            string name,s;
            cin>>name>>s;
            int flag=0;
            for(int j=0;j<s.length();j++){
                switch(s[j])
                {
                    case '1':s[j]='@';flag=1;break;
                    case '0':s[j]='%';flag=1;break;
                    case 'l':s[j]='L';flag=1;break;
                    case 'O':s[j]='o';flag=1;break;
                }
            }
            if(flag){
                string temp=name+" "+s;
                v.push_back(temp);
            }
        }
        int cnt=v.size();
        if(cnt!=0){
            cout<<cnt<<endl;
            for(int i=0;i<cnt;i++)
                cout<<v[i]<<endl;
        }else if(n==1){
            cout<<"There is 1 account and no account is modified"<<endl;
        }else {
            cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
        }
        return 0;
    }
    
    • 1
    • 2
    • 3
    • 4
    • 5
    • 6
    • 7
    • 8
    • 9
    • 10
    • 11
    • 12
    • 13
    • 14
    • 15
    • 16
    • 17
    • 18
    • 19
    • 20
    • 21
    • 22
    • 23
    • 24
    • 25
    • 26
    • 27
    • 28
    • 29
    • 30
    • 31
    • 32
    • 33
    • 34
    • 35
    • 36
    • 37
  • 相关阅读:
    ctfshow web入门 SQl注入 web185--web190
    Gateway基本配置
    基于单片机的贪吃蛇游戏设计仿真
    设计模式:中介者模式
    .\missyou-0.0.1-SNAPSHOT.jar中没有主清单属性
    振弦传感器和无线振弦采集仪在隧道安全监测的解决方案
    canvas的常用函数
    python import相关内容简单介绍
    c高级 day1
    硅谷华人天才CEO被开除,是否会有奇迹发生?
  • 原文地址:https://blog.csdn.net/weixin_49047177/article/details/125535800