H 城是一个旅游胜地,每年都有成千上万的人前来观光。
为方便游客,巴士公司在各个旅游景点及宾馆,饭店等地都设置了巴士站并开通了一些单程巴士线路。
每条单程巴士线路从某个巴士站出发,依次途经若干个巴士站,最终到达终点巴士站。
一名旅客最近到 H 城旅游,他很想去 S 公园游玩,但如果从他所在的饭店没有一路巴士可以直接到达 S 公园,则他可能要先乘某一路巴士坐几站,再下来换乘同一站台的另一路巴士,这样换乘几次后到达 S 公园。
现在用整数 1,2,…N 给 H 城的所有的巴士站编号,约定这名旅客所在饭店的巴士站编号为 1,S 公园巴士站的编号为 N。
写一个程序,帮助这名旅客寻找一个最优乘车方案,使他在从饭店乘车到 S 公园的过程中换乘的次数最少。
输入格式
第一行有两个数字 M 和 N,表示开通了 M 条单程巴士线路,总共有 N 个车站。
从第二行到第 M+1 行依次给出了第 1 条到第 M 条巴士线路的信息,其中第 i+1 行给出的是第 i 条巴士线路的信息,从左至右按运行顺序依次给出了该线路上的所有站号,相邻两个站号之间用一个空格隔开。
输出格式
共一行,如果无法乘巴士从饭店到达 S 公园,则输出 NO,否则输出最少换乘次数,换乘次数为 0 表示不需换车即可到达。
数据范围
1≤M≤100,2≤N≤500
输入样例:
3 7
6 7
4 7 3 6
2 1 3 5
输出样例:
2
解析:
可以把同一条巴士路线中的各个点连接,边权为1.
如样例中第二条巴士路线 4 7 3 6 可以建立4-7,4-3,4-6,7-3,7-6,3-6等边,边权是1.
每换一次车,就是换不同的巴士路线,距离就+1.
不过,要注意读入的问题.
- #include <bits/stdc++.h>
- using namespace std;
- #define ios ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
- #define int long long
- typedef pair<int,int> PII;
- const int N=2e5+10;
- struct node
- {
- int v,w;
- };
- vector <node> g[N];
- int n,m;
- vector <int> a;
- void find(string s)
- {
- for (int i=0;i<s.size();i++)
- {
- int j=i;
- while (j<s.size()&&s[j]!=' ') j++;
- string p=s.substr(i,j-i);
- int x=0,cnt=1;
- for (int k=p.size()-1;k>=0;k--)
- {
- x +=(p[k]-'0')*cnt;
- cnt *=10;
- }
- a.push_back(x);
- i=j;
- }
- }
- int d[N];
- bool vis[N];
- void dijkstra()
- {
- memset(d,0x3f,sizeof d);
- priority_queue <PII,vector<PII>,greater<PII>> q;
- d[1]=0;
- q.push({0,1});
- while (q.size())
- {
- int tance=q.top().first;
- int u=q.top().second;
- q.pop();
- if (vis[u]) continue;
- vis[u]=1;
- for (auto x:g[u])
- {
- int v=x.v,w=x.w;
- if (d[v]>tance+w)
- {
- d[v]=tance+w;
- q.push({d[v],v});
- }
- }
- }
- }
- signed main()
- {
- ios;
- cin>>m>>n;
- cin.ignore();
- while (m--)
- {
- string s;
- getline(cin,s);
- a.clear();
- find(s);
- for (int i=0;i<a.size();i++)
- for (int j=i+1;j<a.size();j++)
- {
- g[a[i]].push_back({a[j],1});
- }
- }
- dijkstra();
- if (d[n]>0x3f3f3f3f/2) cout<<"NO";
- else cout<<d[n]-1;
- return 0;
- }