• 华为vrrp+mstp+dhcp配置案例


    在这里插入图片描述

    sw1:

    vlan batch 10 20 30 40

    stp instance 1 root primary
    stp instance 2 root secondary

    dhcp enable

    stp region-configuration
    region-name a
    revision-level 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    drop-profile default

    ip pool vlan10
    gateway-list 192.168.10.254
    network 192.168.10.0 mask 255.255.255.0
    excluded-ip-address 192.168.10.201 192.168.10.253

    ip pool vlan20
    gateway-list 192.168.20.254
    network 192.168.20.0 mask 255.255.255.0
    excluded-ip-address 192.168.20.201 192.168.20.253

    ip pool vlan30
    gateway-list 192.168.30.254
    network 192.168.30.0 mask 255.255.255.0
    excluded-ip-address 192.168.30.201 192.168.30.253

    ip pool vlan40
    gateway-list 192.168.40.254
    network 192.168.40.0 mask 255.255.255.0
    excluded-ip-address 192.168.40.201 192.168.40.253

    interface Vlanif10
    ip address 192.168.10.1 255.255.255.0
    vrrp vrid 10 virtual-ip 192.168.10.254
    vrrp vrid 10 priority 105
    dhcp select global

    interface Vlanif20
    ip address 192.168.20.1 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254
    vrrp vrid 20 priority 105
    dhcp select global

    interface Vlanif30
    ip address 192.168.30.1 255.255.255.0
    vrrp vrid 30 virtual-ip 192.168.30.254
    dhcp select global

    interface Vlanif40
    ip address 192.168.40.1 255.255.255.0
    vrrp vrid 40 virtual-ip 192.168.40.254
    dhcp select global

    interface MEth0/0/1

    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 10 20 30 40
    mode lacp-static

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    interface GigabitEthernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 30 40

    interface GigabitEthernet0/0/4
    port link-type trunk
    port trunk allow-pass vlan 10 20

    sw2:

    vlan batch 10 20 30 40

    stp instance 1 root secondary
    stp instance 2 root primary

    dhcp enable

    stp region-configuration
    region-name a
    revision-level 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    drop-profile default

    ip pool vlan10
    gateway-list 192.168.10.254
    network 192.168.10.0 mask 255.255.255.0
    excluded-ip-address 192.168.10.1 192.168.10.200

    ip pool vlan20
    gateway-list 192.168.20.254
    network 192.168.20.0 mask 255.255.255.0
    excluded-ip-address 192.168.20.1 192.168.20.200

    ip pool vlan30
    gateway-list 192.168.30.254
    network 192.168.30.0 mask 255.255.255.0
    excluded-ip-address 192.168.30.1 192.168.30.200

    ip pool vlan40
    gateway-list 192.168.40.254
    network 192.168.40.0 mask 255.255.255.0
    excluded-ip-address 192.168.40.1 192.168.40.200

    interface Vlanif10
    ip address 192.168.10.2 255.255.255.0
    vrrp vrid 10 virtual-ip 192.168.10.254
    dhcp select global

    interface Vlanif20
    ip address 192.168.20.2 255.255.255.0
    vrrp vrid 20 virtual-ip 192.168.20.254
    dhcp select global

    interface Vlanif30
    ip address 192.168.30.2 255.255.255.0
    vrrp vrid 30 virtual-ip 192.168.30.254
    vrrp vrid 30 priority 105
    dhcp select global

    interface Vlanif40
    ip address 192.168.40.2 255.255.255.0
    vrrp vrid 40 virtual-ip 192.168.40.254
    vrrp vrid 40 priority 105
    dhcp select global

    interface MEth0/0/1

    interface Eth-Trunk1
    port link-type trunk
    port trunk allow-pass vlan 10 20 30 40
    mode lacp-static

    interface GigabitEthernet0/0/1
    eth-trunk 1

    interface GigabitEthernet0/0/2
    eth-trunk 1

    interface GigabitEthernet0/0/3
    port link-type trunk
    port trunk allow-pass vlan 10 20

    interface GigabitEthernet0/0/4
    port link-type trunk
    port trunk allow-pass vlan 30 40

    sw3:

    vlan batch 10 20

    stp region-configuration
    region-name a
    revision-level 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    drop-profile default

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 10 20

    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 10 20

    interface GigabitEthernet0/0/3
    port link-type access
    port default vlan 10

    interface GigabitEthernet0/0/4
    port link-type access
    port default vlan 20

    sw4:

    vlan batch 30 40

    stp region-configuration
    region-name a
    revision-level 1
    instance 1 vlan 10 20
    instance 2 vlan 30 40
    active region-configuration

    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk allow-pass vlan 30 40

    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk allow-pass vlan 30 40

    interface GigabitEthernet0/0/3
    port link-type access
    port default vlan 30

    interface GigabitEthernet0/0/4
    port link-type access
    port default vlan 40

  • 相关阅读:
    SpringBoot MongoDB GridFsTemplate实现文件管理
    一文熟悉 Go 的基础语法和基本数据类型
    【Leetcode笔记】236.二叉树的最近公共祖先
    计算机网络之数据链路层
    12【事务的隔离级别】
    Mybatis的学习(一)只Mybatis的介绍和使用
    SpringMVC
    linux系统---防火墙
    spring security 用户授权/访问控制
    Nginx动态反向代理(2022/11/12)
  • 原文地址:https://blog.csdn.net/ydaxia110/article/details/134191293